You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
Andrey Volk 2572336653
Update Drone CI signature. (#126)
4 months ago
.vscode Initial commit 4 years ago
KSTest Initial commit 4 years ago
cmake Fix typo in ksutil.cmake ksutil_target_check_include_file 3 years ago
src Fix kws_raw_read_blocking() zero reads bug for iOS 15. 1 year ago
tests Fix overflow when kws_raw_read() fills buffer. Add kws_string_read() which will always NULL terminate data read from websocket. 1 year ago
win Update libks to 1.8.0 on Windows and use openssl 1.1.x 10 months ago
.drone.yml Update Drone CI signature. (#126) 4 months ago
.gitignore Update .gitignore 4 years ago
CMakeLists.txt version bump 10 months ago
CODING_GUIDELINES Initial commit 4 years ago
README add support for RPM package building on Centos 7.x 4 years ago
copyright Initial commit 4 years ago
libks.code-workspace Initial commit 4 years ago
libks.pc.in Revert "Cflags should point to include folder, not to include/libks" 2 years ago
uninstall.cmake.in Initial commit 4 years ago

README

To build use cmake (Minimum version 3.7.2):
cmake .
make

To install:
make install

To un-install:
make uninstall

To build debug (no optimizations, symbols - this is the default):
cmake . -DCMAKE_BUILD_TYPE=Debug
make

To build release (optimizations, symbols):
cmake . -DCMAKE_BUILD_TYPE=Release
make

To build to a custom installation prefix (default is /usr):
cmake . -DCMAKE_INSTALL_PREFIX:PATH=/usr
make

To build with openssl on non-standard location (e.g. on Mac):
OPENSSL_ROOT_DIR=/usr/local/opt/openssl cmake . -DCMAKE_INSTALL_PREFIX:PATH=/usr/local

To run tests:
ctest .

To build release package with build number 42:
PACKAGE_RELEASE="42" cmake . -DCMAKE_BUILD_TYPE=Release && make package

To buld CMAKE from source
wget https://cmake.org/files/v3.7/cmake-3.7.2.tar.gz
tar -zxvf cmake-3.7.2.tar.gz
cd cmake-3.7.2
./bootstrap --prefix=/usr/local
make
make install
/usr/local/bin/cmake --version

Centos dependencies:
- yum groupinstall "Development Tools"
- yum install libuuid-devel libatomic openssl-devel